Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums

Search 4x4Wire




Recent Posts
Impact's 'Accel' Keeps You Safe
by 4x4Wire
Yesterday at 11:39 PM
Edelbrock's E-Force Promo Is Back
by 4x4Wire
Yesterday at 05:14 PM
Running out of engine options, will this work?
by ENG1N33R
Yesterday at 03:03 AM
Temp sensor on 2.6L
by rxinhed
Yesterday at 01:59 AM
Gen 1 rear leaf springs and shackles
by ENG1N33R
09/26/16 10:40 PM
Adjustable panhard rod
by TOASTY
09/24/16 02:00 AM
How to check timing chain tension - 2.6 1987 Monte
by Mudraider
09/23/16 10:53 PM
Support 4x4Wire
New Topics on TrailTalk
Impact's 'Accel' Keeps You Safe
by 4x4Wire
Yesterday at 11:39 PM
Edelbrock's E-Force Promo Is Back
by 4x4Wire
Yesterday at 05:14 PM
Gen 1 rear leaf springs and shackles
by ENG1N33R
09/26/16 10:40 PM
JKS: Jeep JK EVAP Canister Skid Plate
by 4x4Wire
09/23/16 07:50 PM
Edelbrock's Top It Off Promotion Is Back
by 4x4Wire
09/22/16 05:13 PM
How to check timing chain tension - 2.6 1987 Monte
by castaway
09/22/16 03:31 AM
4x4 Gallery
Clearance check!
Testing the new Kenda Klever 31x10.50x15
My '88
4x4Wire YJ
IFS Holdout
More News on the 'Wire
4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online
0 registered (), 38 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
14,488 Registered Members
38 Forums
136,564 Topics
1,077,333 Posts

Most users ever online: 309 @ 09/15/15 01:18 AM
Topic Options
Rate This Topic
#817752 - 06/09/07 11:03 PM 1999 Isuzu Trooper High Idle Problem
Larry_G Offline
Need a Spot
Registered: 07/01/04
Posts: 3
Loc: Houston, TX
Hi,
I have a high idle problem on my 1999 Isusu Trooper with 95K miles. There is no MIL light(check engine) on my dash. The idle creeps up a little at a time until it gets to 1500 rpm in drive. The rpm in neutral have goone as high as 2000. The AC compressor will increase the RPM by about 300 rpm when it comes on. I can pull the ECM fuse and reset the idle to normal. I have cleaned the EGR, Throdle Body, MAF, IAC and has had no effect. I have changed the TPS, Coolant Temp Sensor, MAF, EGR, PCV, IAC. The idle creaps up a little each time I restart the engine. The idle is smooth but high. It does not appear to be a vacuum leak. The problem is not temperature dependent. This is driving me nuts. I have had this problem about 6 months. Any ideas of what to try next? I am stumped.
Thanks, Larry
Top
Support our sponsors

Entire topic
Subject Posted by Posted
1999 Isuzu Trooper High Idle Problem Larry_G 06/09/07 11:03 PM
Re: 1999 Isuzu Trooper High Idle Problem litnin 06/10/07 06:53 PM

Moderator:  houlster, jezeric, Jim_Paget, strawmyers 

Search the 4x4Wire site:



4x4Wire Portal: 4x4Wire | 4x4Voice | OutdoorWire | MUIRNet-News | TrailTalk Forums | Site Index | FaceBook | Google+Google+
4x4Wire Archive: 4x4 Tech | 4x4 Reviews | 4x4 News | 4x4 Trails | Destinations | 4x4 Access
Jeep | Toyota | Mitsubishi | Isuzu
More 4x4Wire: Toyota FAQ | Toyota Projects | Toyota Maintenance | Toyota 4Runner | Toyota Tech
Jeep Tech | Jeep Projects | Jeep News | Jeep Reviews | Jeep Gallery


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting
Copyright (c) 2000-2016 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.