Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums

Search 4x4Wire




Recent Posts
91 Trooper meets 95 3.4 V6, shotgun wedding!
by Jim_Paget
Today at 01:39 AM
Fresh 94SR at wreckers.. What to get?
by fhuzz
Yesterday at 09:20 PM
89 V6 power steering can be replaced with Gen 2
by fhuzz
Yesterday at 09:09 PM
6g72 sohc diamante engine swap ?
by turboed83
Yesterday at 02:50 AM
Fuel Filler Hose Fun
by bearingman
07/29/16 07:15 PM
97 montero sr Any one added a fan or two?
by ES_97Sport
07/29/16 05:56 PM
96 Pajero 4G64 Mikuni carburator issues.
by Mudraider
07/29/16 12:32 AM
Support 4x4Wire
New Topics on TrailTalk
Fresh 94SR at wreckers.. What to get?
by fhuzz
Yesterday at 09:20 PM
96 Pajero 4G64 Mikuni carburator issues.
by IslandShort
07/29/16 12:23 AM
6g72 sohc diamante engine swap ?
by turboed83
07/28/16 11:23 PM
Fuel Filler Hose Fun
by DRaider90
07/28/16 12:35 AM
95 Sportage Won't Start
by joelrios1
07/27/16 10:49 PM
4x4 Gallery
Clearance check!
Testing the new Kenda Klever 31x10.50x15
My '88
4x4Wire YJ
IFS Holdout
More News on the 'Wire
4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online
0 registered (), 57 Guests and 3 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
14,441 Registered Members
38 Forums
136,434 Topics
1,077,038 Posts

Most users ever online: 309 @ 09/15/15 01:18 AM
Topic Options
Rate This Topic
#817752 - 06/09/07 11:03 PM 1999 Isuzu Trooper High Idle Problem
Larry_G Offline
Need a Spot
Registered: 07/01/04
Posts: 3
Loc: Houston, TX
Hi,
I have a high idle problem on my 1999 Isusu Trooper with 95K miles. There is no MIL light(check engine) on my dash. The idle creeps up a little at a time until it gets to 1500 rpm in drive. The rpm in neutral have goone as high as 2000. The AC compressor will increase the RPM by about 300 rpm when it comes on. I can pull the ECM fuse and reset the idle to normal. I have cleaned the EGR, Throdle Body, MAF, IAC and has had no effect. I have changed the TPS, Coolant Temp Sensor, MAF, EGR, PCV, IAC. The idle creaps up a little each time I restart the engine. The idle is smooth but high. It does not appear to be a vacuum leak. The problem is not temperature dependent. This is driving me nuts. I have had this problem about 6 months. Any ideas of what to try next? I am stumped.
Thanks, Larry
Top
Support our sponsors

Entire topic
Subject Posted by Posted
1999 Isuzu Trooper High Idle Problem Larry_G 06/09/07 11:03 PM
Re: 1999 Isuzu Trooper High Idle Problem litnin 06/10/07 06:53 PM

Moderator:  houlster, jezeric, Jim_Paget, strawmyers 

Search the 4x4Wire site:



4x4Wire Portal: 4x4Wire | 4x4Voice | OutdoorWire | MUIRNet-News | TrailTalk Forums | Site Index | FaceBook | Google+Google+
4x4Wire Archive: 4x4 Tech | 4x4 Reviews | 4x4 News | 4x4 Trails | Destinations | 4x4 Access
Jeep | Toyota | Mitsubishi | Isuzu
More 4x4Wire: Toyota FAQ | Toyota Projects | Toyota Maintenance | Toyota 4Runner | Toyota Tech
Jeep Tech | Jeep Projects | Jeep News | Jeep Reviews | Jeep Gallery


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting
Copyright (c) 2000-2016 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.