Extreme Terrain
4x4Wire Trail Talk Forums: Jeep, Toyota, Mitsubishi, Pajero, Isuzu, Kia, 4WD, 4x4, SUV, Off-Road and OutdoorWire Forums

Search 4x4Wire




Recent Posts
New Activity
by PajEvo
05/03/16 07:48 PM
Build threads - want 'em listed in one place?
by PajEvo
05/03/16 07:47 PM
Gen 1 high idle, wax pellets talk
by JohnnyBfromPeoria
05/03/16 07:38 PM
1999 Montero Sport Limited 3.5L crawler build
by ES_97Sport
05/03/16 06:27 PM
Transplant 6G74 engine into a 6G72 Montero Sport?
by ES_97Sport
05/03/16 04:47 PM
Exhaust Manifold Bold Number
by rxinhed
05/03/16 04:46 PM
Round headlights on a Mighty Max? Awesome!
by TOASTY
05/03/16 10:41 AM
Support 4x4Wire
New Topics on TrailTalk
Exhaust Manifold Bold Number
by jdavis
05/02/16 10:31 PM
New Suzuki GSX1300R Connecting Rods comes
by Racerfanny
05/02/16 10:04 PM
4G64 DOHC with custom AX5 trans 4 sale.
by 87monty
05/01/16 07:20 PM
Build threads - want 'em listed in one place?
by PajEvo
04/30/16 09:49 PM
87Monty will have a 4BT
by rxinhed
04/30/16 07:11 PM
4x4 Gallery
Clearance check!
Testing the new Kenda Klever 31x10.50x15
My '88
4x4Wire YJ
IFS Holdout
More News on the 'Wire
4x4Voice
4x4Wire
MUIRNet-News
OutdoorWire
Who's Online
1 registered (1 invisible), 53 Guests and 69 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
14,353 Registered Members
44 Forums
136,444 Topics
1,076,740 Posts

Most users ever online: 309 @ 09/14/15 08:18 PM
Topic Options
Rate This Topic
#817752 - 06/09/07 06:03 PM 1999 Isuzu Trooper High Idle Problem
Larry_G Offline
Need a Spot
Registered: 07/01/04
Posts: 3
Loc: Houston, TX
Hi,
I have a high idle problem on my 1999 Isusu Trooper with 95K miles. There is no MIL light(check engine) on my dash. The idle creeps up a little at a time until it gets to 1500 rpm in drive. The rpm in neutral have goone as high as 2000. The AC compressor will increase the RPM by about 300 rpm when it comes on. I can pull the ECM fuse and reset the idle to normal. I have cleaned the EGR, Throdle Body, MAF, IAC and has had no effect. I have changed the TPS, Coolant Temp Sensor, MAF, EGR, PCV, IAC. The idle creaps up a little each time I restart the engine. The idle is smooth but high. It does not appear to be a vacuum leak. The problem is not temperature dependent. This is driving me nuts. I have had this problem about 6 months. Any ideas of what to try next? I am stumped.
Thanks, Larry
Top

Entire topic
Subject Posted by Posted
1999 Isuzu Trooper High Idle Problem Larry_G 06/09/07 06:03 PM
Re: 1999 Isuzu Trooper High Idle Problem litnin 06/10/07 01:53 PM

Moderator:  houlster, jezeric, Jim_Paget, strawmyers 

Search the 4x4Wire site:



4x4Wire Portal: 4x4Wire | 4x4Voice | OutdoorWire | MUIRNet-News | TrailTalk Forums | Site Index | FaceBook | Google+Google+
4x4Wire Archive: 4x4 Tech | 4x4 Reviews | 4x4 News | 4x4 Trails | Destinations | 4x4 Access
Jeep | Toyota | Mitsubishi | Isuzu
More 4x4Wire: Toyota FAQ | Toyota Projects | Toyota Maintenance | Toyota 4Runner | Toyota Tech
Jeep Tech | Jeep Projects | Jeep News | Jeep Reviews | Jeep Gallery


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting
Copyright (c) 2000-2016 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.